PGIトップ › PGI技術情報・TIPS › サポート OS

PGI Compiler 2015 サポートOS

対象 PGIコンパイラ サポート OS

PGI 2015 がサポートする Operating System とその特性

 PGI コンパイラ製品がサポートする Linux Distribution、Windows®OS X の種別とその OS 上で利用可能な機能、ライブラリ等を以下に纏めました。

Linux Distributions

 PGI コンパイラ製品がサポートする Linux Distributionを以下に纏めました。なお、過去の PGI コンパイラのバージョンをサポートする Linux OS の種類に関しては、こちらをご覧ください

Linux Systems Supported by PGI Workstation 2015
Distribution 64-bit HyperThreading NPTL NUMA glibc GCC
RHEL 7.0 Yes Yes Yes Yes 2.17 4.8.2
RHEL 6.5 Yes Yes Yes Yes 2.12 4.4.7
RHEL 6.4 Yes Yes Yes Yes 2.12 4.4.7
RHEL 6.3 Yes Yes Yes Yes 2.12 4.4.6
RHEL 6.2 Yes Yes Yes Yes 2.12 4.4.6
RHEL 6.1 Yes Yes Yes Yes 2.12 4.4.5
RHEL 6.0 Yes Yes Yes Yes 2.12 4.4.4
RHEL 5.6 Yes Yes Yes Yes 2.12 4.4.4
RHEL 5.5 Yes Yes Yes Yes 2.5 4.1.2
RHEL 5.4 Yes Yes Yes Yes 2.5 4.1.2
RHEL 5.3 Yes Yes Yes Yes 2.5 4.1.2
RHEL 5.0 Yes Yes Yes Yes 2.5 4.1.2
RHEL 4.8 Yes Yes Yes Yes 2.3.4 3.4.3
CentOS, Scientific Linux も 上記 RHEL の同じバージョンで使用できます。
Fedora 21 Yes Yes Yes No 2.20 4.9.2
Fedora 20 Yes Yes Yes No 2.18 4.8.2
Fedora 19 Yes Yes Yes No 2.17 4.8.1
Fedora 18 Yes Yes Yes No 2.16 4.7
Fedora 17 Yes Yes Yes No 2.15 4.7
Fedora 16 Yes Yes Yes No 2.14.90 4.6.2
Fedora 15 Yes Yes Yes No 2.13 4.6.0
Fedora 14 Yes Yes Yes No 2.12 4.4.5
Fedora 13 Yes Yes Yes No 2.12 4.4.4
Fedora 12 Yes Yes Yes No 2.11 4.4.2
Fedora 11 Yes Yes Yes No 2.10.1 4.4
Fedora 10 Yes Yes Yes No 2.9 4.3.2
Fedora 9 Yes Yes Yes Yes 2.8 4.3.0
Fedora 8 Yes Yes Yes Yes 2.7 4.1.2
Fedora 7 Yes Yes Yes Yes 2.6 4.1.2
Fedora 6 Yes Yes Yes Yes 2.5 4.1.1
Fedora 5 Yes Yes Yes Yes 2.4 4.1.0
Fedora 4 Yes Yes Yes Yes 2.3.5 4.0.0
SUSE 13.2 Yes Yes Yes Yes 2.19 4.8.3
SUSE 13.1 Yes Yes Yes Yes 2.18 4.8.1
SUSE 12.3 Yes Yes Yes Yes 2.17 4.7.2
SUSE 12.2 Yes Yes Yes Yes 2.15 4.7
SUSE 12.1 Yes Yes Yes Yes 2.14.1 4.6.2
SUSE 11.3 Yes Yes Yes Yes 2.11.2 4.5
SUSE 11.2 Yes Yes Yes Yes 2.10.1 4.3.3
SUSE 11.1 Yes Yes Yes Yes 2.9 4.4.1
SUSE 11.0 Yes Yes Yes Yes 2.8 4.3.0
SUSE 10.3 Yes Yes Yes Yes 2.6.1 4.2.1
SUSE 10.2 Yes Yes Yes Yes 2.5 4.1.0
SUSE 10.1 Yes Yes Yes Yes 2.4 4.1.0
SUSE 10.0 Yes YES YES Yes 2.3.5 4.0.2
SuSE 9.3 Yes Yes Yes Yes 2.3.4 3.3.5
SLES 11 sp3 Yes Yes Yes Yes 2.11.3 4.3.4
SLES 11 sp1/sp2 Yes Yes Yes Yes 2.9 4.3.3
SLES 10 Yes Yes Yes Yes 2.4 4.1.2
Ubuntu 14.10 Yes Yes Yes Yes 2.19 4.9.1
Ubuntu 14.04 Yes Yes Yes Yes 2.19 4.8.2
Ubuntu 13.10 Yes Yes Yes Yes 2.17 4.8.1
Ubuntu 13.04 Yes Yes Yes Yes 2.17 4.7.3
Ubuntu 12.10 Yes Yes Yes Yes 2.15 4.7.2
Ubuntu 12.04 Yes Yes Yes Yes 2.14 4.6.3
Ubuntu 11.10 Yes Yes Yes Yes 2.13.20 4.6.1
Ubuntu 11.04 Yes Yes Yes Yes 2.13.0 4.5.2
Ubuntu 10.10 Yes Yes Yes Yes 2.12.1 4.4.5
Ubuntu 10.04
(PGI10.6~)
Yes Yes Yes Yes 2.11.1 4.4.3
Ubuntu 9.10 Yes Yes Yes Yes 2.10.1 4.4.1
Ubuntu 9.04 Yes Yes Yes Yes 2.9 4.3.3
Ubuntu 8.10 Yes Yes Yes Yes 2.8 4.3.2
Ubuntu 8.04 Yes Yes Yes Yes 2.7 4.2.1
  • NPTL は、新しい Linux distributions でサポートした Native Posix Threads Library (NPTL) です。PGI コンパイラは、OpenMP あるいは自動並列化機能において使用するスレッドライブラリを自動的にこの NPTL を使用する形を取ります。
  • NUMA(Non-Uniform Memory Access) は、NUMAライブラリに対応しているOSを意味します。マルチプロセッサ AMD Opteron や Intel Nehalem プロセッサベースのシステムでは、メモリアクセスのレイテンシが異なるNUMAアーキテクチャを採用しています。NUMAとは、あるプロセッサからメモリ領域へのアクセス時間が異なるアーキテクチャを言います。SuSE9.2/9.3、SUSE 10.0、SLES 9 以上、RHEL 4、Fedora Core 4 以上は、コンパイラによって利用可能な NUMAライブラリを含んでいるため、このライブラリをインクルードします。また、このランタイムライブラリによって、メモリのデータのアクセスを最適化します。
  • 2011年11月に発売された AMD Bulldozer プロセッサに対応する Linux 上の開発環境 GNU binutil は、バージョン 2.20.51 以上ですのでご注意下さい。これ以前の binutil では、 その assembler にバグが存在します。Ubuntu 11.04 以上、Red Hat 6.2 以上、SUSE Linux Enterprise 11 Service Pack 2 以上となります。なお、Debian 6.0.x (Squeeze) はデフォルトでは対応しておりませんので、binutil のバージョンを個別にバージョンアップする必要があります。
  • 現在のシステムの Linux distribution とバージョン名は、/etc/issue ファイルの中に記述されております。あるいは、cat /proc/version コマンドで出力されます。
  • 現在のシステムの glibc のバージョンを知りたい場合は、コマンド "/lib/libc.so.6" を実行してください。(64ビットの場合は、/lib64/libc.so.6)
  • 現在のシステムのアーキテクチャ名を知りたい場合は、コマンド "arch" を実行してください。
  • 現在のシステム情報の全てを知りたい場合は、 コマンド "uname -a" を実行して下さい。
  • 現在の CPU 情報は、/proc/cpuinfo ファイルの中に記述されております。

Windows®

 以下の表は、32ビットならびに64ビット Windows®上で使用可能な対応 OS を示します。

Windows® Systems Supported by PGI Workstation 2015
OS Type 64-bit HyperThreading NPTL NUMA glibc GCC
Microsoft
Windows
(32 ビット)
8.1 No Yes N/A Yes N/A N/A
8 No Yes N/A Yes N/A N/A
Server
2012
No Yes N/A Yes N/A N/A
7 No Yes N/A Yes N/A N/A
Server
2008 R2
No Yes N/A Yes N/A N/A
Microsoft
Windows
(64 ビット)
8.1 Yes Yes N/A Yes N/A N/A
8 Yes Yes N/A Yes N/A N/A
Server
2012
Yes Yes N/A Yes N/A N/A
7 Yes Yes N/A Yes N/A N/A
Server
2008 R2
Yes Yes N/A Yes N/A N/A

次期 PGI 2016 (2016年リリース)においては、Windows版の C++ コンパイラの提供が廃止(終息)されます。Windows版は、Fortran 並びに C11コンパイラのみの提供に変更となります。

Apple OS X

 以下の表は、32ビットならびに64ビット OS X 上で使用可能な対応 OS バージョンを示します。

OS X Systems Supported by PGI Workstation 2015
OS Type 64-bit HyperThreading NPTL NUMA glibc GCC
Apple
OS X
Yosemite(10.10) Yes No N/A N/A N/A 4.2.1
Apple
OS X
Mavericks(10.9) Yes No N/A N/A N/A 4.2.1
Mountain Lion(10.8) Yes No N/A N/A N/A 4.2.1
Lion(10.7) Yes No N/A N/A N/A 4.2.1
  • (重要)OS X のバージョン(Snow Leopard/Lion/Mountain Lion/Mavericks) に対応した Xcode 開発環境を必ずご用意下さい。この組み合わせが悪い場合は、PGIソフトウェアのインストールが失敗します
    OS X のバージョンとそれに対応する Xcode バージョン
    OS X 10.6 (Snow Leopard) Xcode 3.2 以上 4.5まで
    OS X 10.7/10.8 (Lion, Mountain Lion) Xcode 4.1, 4.2, 4.3, 4.4,
    4.5
    OS X 10.9 (Mavericks) Xcode 5.0, newer
    OS X 10.10 (Yosamite) Xcode 6.1, newer
PGI製品問合せはソフテックへ